aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2020-01-26 15:46:58 +0100
committerPeter Wu <peter@lekensteyn.nl>2020-01-29 22:18:23 +0000
commitec7a84f14e725f6070cdfbd5e45827014ba1784b (patch)
tree3a5f0ad72ef943926ae052aa4c5b6af324c5e1c6 /CMakeLists.txt
parent8efde3980524daf84405d5778872503ea4f6c9cf (diff)
cmake: add libcap package properties.
Change-Id: Ie3ea8a51d6cf200b3815b0046255bf0208240287 Reviewed-on: https://code.wireshark.org/review/35954 Petri-Dish: Dario Lombardo <lomato@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 134345501b..9b6d65d3bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1571,6 +1571,11 @@ foreach( _cfg_file ${CFG_OUT_FILES} )
endforeach()
include(FeatureSummary)
+set_package_properties(CAP PROPERTIES
+ DESCRIPTION "The Libcap package implements the user-space interfaces to the POSIX 1003.1e capabilities available in Linux kernels"
+ URL "https://sites.google.com/site/fullycapable/"
+ PURPOSE "Allow packet captures without running as root"
+)
set_package_properties(SBC PROPERTIES
DESCRIPTION "Bluetooth low-complexity, subband codec (SBC) decoder"
URL "https://git.kernel.org/pub/scm/bluetooth/sbc.git"