aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2021-11-03 15:23:10 +0100
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-11-03 16:04:46 +0000
commite84acd86eb92b86d2323268e5b48155d98ea08dc (patch)
tree6c1ac0a0293185b03bd51ec9d581fe1a3e845c82 /CMakeLists.txt
parent46e08f0f67afbebac9411ab41ba0db25793363ad (diff)
CMake: fix macOS build without Asciidoctor
Fix an error when running cmake on macOS without Asciidoctor: The dependency target "manpages" of target "wireshark" does not exist. Fixes: 44bd3a7d7923 ("CMake+Docs: Update our man page targets.")
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb5c992446..50c30f7f5e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2530,7 +2530,11 @@ if(BUILD_wireshark AND QT_FOUND)
endif()
if(ENABLE_APPLICATION_BUNDLE)
- add_dependencies(wireshark manpages)
+ if(ASCIIDOCTOR_FOUND)
+ # Make sure to generate files referenced by
+ # BUNDLE_RESOURCE_SHARE_MAN1_FILES
+ add_dependencies(wireshark manpages)
+ endif()
set_target_properties(
wireshark PROPERTIES
MACOSX_BUNDLE_INFO_PLIST ${CMAKE_BINARY_DIR}/packaging/macosx/Info.plist