aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-08-13 08:10:44 -0700
committerGerald Combs <gerald@wireshark.org>2014-08-13 23:00:25 +0000
commite3978271dfea090e9d2d98b1fa58a5636411e614 (patch)
tree2eb5e2818e95e1ca48bc03a7a8d4bca0f405e267 /CMakeLists.txt
parenta83f67cb85926e42314d25f7ddbbd66dbae5b6ed (diff)
Windows Qt: Add taskbar progress support
Add support for the taskbar progress indicator on Windows via QtWinExtras. It is almost as if we're a grown up Windows application. Change-Id: I378206b49510d4bd08f2437d8e9a1b01bc6f1351 Reviewed-on: https://code.wireshark.org/review/3576 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9b24c070b5..fa377eedac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -522,6 +522,9 @@ if(BUILD_qtshark)
if (APPLE)
set(PACKAGELIST ${PACKAGELIST} Qt5MacExtras)
endif()
+ if( WIN32 )
+ set(PACKAGELIST ${PACKAGELIST} Qt5WinExtras)
+ endif()
set(QT_VERSION 5)
else()
set(PACKAGELIST ${PACKAGELIST} Qt4)