aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMaarten Bezemer <maarten.bezemer@gmail.com>2014-11-11 14:41:01 +0100
committerMichael Mann <mmann78@netscape.net>2014-12-16 14:18:02 +0000
commitce687075f04a950f8fd95d6b517c11eb2ee9fa62 (patch)
treedc8c1ad29bc90842546dc31b7d0c660b72f236ef /CMakeLists.txt
parentec28d8755ba1b0fff1b07ac13c3264465e0eb635 (diff)
Add cmake helper files for finding wireshark
These files make it possible to use the cmake command find_package(Wirehark) to obtain information about the wireshark installation. Change-Id: I5af7c4e7b53b99cd473e04905a92bac267cd9b83 Reviewed-on: https://code.wireshark.org/review/5235 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db1440c934..056596270a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1789,6 +1789,18 @@ CHECKAPI(
${WIRESHARK_SRC}
)
+set(CMAKE_INSTALL_MODULES_DIR ${CMAKE_INSTALL_LIBDIR}/@CPACK_PACKAGE_NAME@)
+configure_file("${CMAKE_MODULE_PATH}/WiresharkConfig.cmake.in" "${CMAKE_BINARY_DIR}/WiresharkConfig.cmake" @ONLY)
+configure_file("${CMAKE_MODULE_PATH}/WiresharkConfigVersion.cmake.in" "${CMAKE_BINARY_DIR}/WiresharkConfigVersion.cmake" @ONLY)
+install(
+ FILES
+ ${CMAKE_MODULE_PATH}/FindWireshark.cmake
+ ${CMAKE_BINARY_DIR}/WiresharkConfig.cmake
+ ${CMAKE_BINARY_DIR}/WiresharkConfigVersion.cmake
+ DESTINATION
+ ${CMAKE_INSTALL_MODULES_DIR}
+)
+
if(DOC_DIR)
message(STATUS "Docdir install: ${DOC_DIR}")
INSTALL(