aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-01-06 16:59:32 -0800
committerGerald Combs <gerald@wireshark.org>2015-01-08 22:05:38 +0000
commitcd7408e526df2596b478ab622b90a8a2a60890c2 (patch)
tree21c87caa27168811a7b4858b02e0b0798f5d10d1 /CMakeLists.txt
parent4b8c66891a830716bf1569b9d6aa6742bc47f81c (diff)
CMake: Enable DocBook on Windows.
Add a wrapper script and CMake macros which lets us run Cygwin's a2x from Windows. Add *another* wrapper script that ignores the return value of hhc.exe. Move the ASCIIDOC2DOCBOOK macro to FindASCIIDOC.cmake. Add FindHHC.cmake. Add hints to FindFOP.cmake. Use unique file names in the HTML Help chain in an attempt to avoid a race condition. To do: - Fix curly quote in HHC title. Change-Id: I9b154b7fbd02703656e2ab380199ec0a6db4e36d Reviewed-on: https://code.wireshark.org/review/6379 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebba9186e4..842f6a8ead 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -870,11 +870,7 @@ add_subdirectory( asn1 EXCLUDE_FROM_ALL )
add_subdirectory( capchild )
add_subdirectory( caputils )
add_subdirectory( codecs )
-if (NOT WIN32)
- # Some work will be required for Windows. See the notes at the top
- # of FindASCIIDOC.cmake.
- add_subdirectory( docbook )
-endif()
+add_subdirectory( docbook )
add_subdirectory( epan )
add_subdirectory( tools/lemon )
add_subdirectory( ui )