aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2021-11-12 10:50:29 +0000
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-11-12 11:19:34 +0000
commitb8f9758742082554412c158e6a9fcddab4d2b48f (patch)
tree938662fe17bd5df16b6ebac04b41d822b8330240 /CMakeLists.txt
parentc3599a961634595afdfdacac2fafde762f6299b4 (diff)
MSYS2: Use system SpeexDSP package
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d416966606..416c3e91cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1360,9 +1360,10 @@ find_package(DOXYGEN)
# The SpeexDSP resampler is required iff building wireshark or sharkd.
if(BUILD_wireshark OR BUILD_sharkd)
- # On Windows we just use the bundled resampler. We don't have
- # our own binary package for SpeexDSP and don't bother searching.
- if (NOT WIN32)
+ # We don't provide a binary package for SpeexDSP in our repository.
+ # If using the repository don't bother searching for a system SpeexDSP
+ # installation and just use the bundled resampler code instead.
+ if (NOT USE_REPOSITORY)
find_package(SpeexDSP)
endif()
if(SpeexDSP_FOUND)