aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-06-10 00:40:52 +0100
committerJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2021-06-10 00:57:49 +0100
commitaf2a88cd18e51869465080ef19492896c6ec311b (patch)
treec3d193d5b72a489784d34672dd56b7ae42070b32 /CMakeLists.txt
parent1a702e5430d2a750ed234bc3a7fdc052086f5124 (diff)
CMake: Reverse logic to handle debug code
Only enabling debug code by default with Debug build type seems overly restrictive; debug output is still conditional on the log level.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a2ce8bcab4..7bb04dd0e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -432,7 +432,7 @@ set_property(DIRECTORY
"G_DISABLE_DEPRECATED"
"G_DISABLE_SINGLE_INCLUDES"
$<$<OR:$<BOOL:${DISABLE_ASSERT}>,$<CONFIG:Release>>:WS_DISABLE_ASSERT>
- $<$<OR:$<BOOL:${ENABLE_DEBUG}>,$<CONFIG:Debug>>:WS_DEBUG>
+ $<$<OR:$<BOOL:${DISABLE_DEBUG}>,$<CONFIG:Release>>:WS_DISABLE_DEBUG>
)
if( CMAKE_C_COMPILER_ID MATCHES "MSVC")