aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2022-12-15 18:54:48 +0000
committerJoão Valverde <j@v6e.pt>2022-12-16 11:11:28 +0000
commitae148498649e38105607e9da2262fc276ffe2049 (patch)
treea603adaab2f0b334fb39eb72f0644a7ab91da838 /CMakeLists.txt
parenta4f56e90a66e81f85d8e5f81eb3e5781198311c3 (diff)
Windows: Use SpeexDSP binary package
Remove bundled code and use vcpkg binary library instead.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 4 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7abb22db86..8f4758ae64 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1327,19 +1327,7 @@ find_package(DOXYGEN)
# The SpeexDSP resampler is required iff building wireshark or sharkd.
if(BUILD_wireshark OR BUILD_logray OR BUILD_sharkd)
- # We don't provide a binary package for SpeexDSP in our repository.
- # If using the repository don't bother searching for a system SpeexDSP
- # installation and just use the bundled resampler code instead.
- if (NOT USE_REPOSITORY)
- find_package(SpeexDSP)
- endif()
- if(SpeexDSP_FOUND)
- set(HAVE_SPEEXDSP 1)
- else()
- add_subdirectory(speexdsp)
- set(SPEEXDSP_INCLUDE_DIRS "")
- set(SPEEXDSP_LIBRARIES "speexresampler")
- endif()
+ find_package(SpeexDSP REQUIRED)
endif()
# Generate the distribution tarball.
@@ -2171,6 +2159,9 @@ if(USE_REPOSITORY)
list (APPEND THIRD_PARTY_DLLS "${BROTLI_DLL_DIR}/${_dll}")
endforeach(_dll)
endif(BROTLI_FOUND)
+ if (SPEEXDSP_FOUND)
+ list (APPEND THIRD_PARTY_DLLS "${SPEEXDSP_DLL_DIR}/${SPEEXDSP_DLL}")
+ endif()
# With libs downloaded to c:/wireshark-win64-libs this currently
# (early 2018) expands to about 1900 characters.