aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2023-11-10 11:59:32 -0800
committerGerald Combs <gerald@wireshark.org>2023-11-10 21:00:30 +0000
commita5e0be51df50e0e8a8f3091413aa036847282369 (patch)
treea5d0cf8db271ac36abf621c6ec77dbff2b242f68 /CMakeLists.txt
parentcefcf0ac02352757a39bd3ab9defb4ec3e089819 (diff)
Windows: Upgrade Minizip to 1.3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef3e9a435e..6a7906dd61 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2210,9 +2210,10 @@ if(USE_REPOSITORY)
list (APPEND THIRD_PARTY_DLLS "${LZ4_DLL_DIR}/${LZ4_DLL}")
list (APPEND THIRD_PARTY_PDBS "${LZ4_DLL_DIR}/${LZ4_PDB}")
endif(LZ4_FOUND)
- if (ZSTD_FOUND)
- list (APPEND THIRD_PARTY_DLLS "${ZSTD_DLL_DIR}/${ZSTD_DLL}")
- endif(ZSTD_FOUND)
+ if (MINIZIP_FOUND)
+ list (APPEND THIRD_PARTY_DLLS "${MINIZIP_DLL_DIR}/${MINIZIP_DLL}")
+ list (APPEND THIRD_PARTY_PDBS "${MINIZIP_DLL_DIR}/${MINIZIP_PDB}")
+ endif()
if (NGHTTP2_FOUND)
list (APPEND THIRD_PARTY_DLLS "${NGHTTP2_DLL_DIR}/${NGHTTP2_DLL}")
list (APPEND THIRD_PARTY_PDBS "${NGHTTP2_DLL_DIR}/${NGHTTP2_PDB}")
@@ -2306,6 +2307,9 @@ if(USE_REPOSITORY)
if (SPEEXDSP_FOUND)
list (APPEND THIRD_PARTY_DLLS "${SPEEXDSP_DLL_DIR}/${SPEEXDSP_DLL}")
endif()
+ if (ZSTD_FOUND)
+ list (APPEND THIRD_PARTY_DLLS "${ZSTD_DLL_DIR}/${ZSTD_DLL}")
+ endif()
# With libs downloaded to c:/wireshark-x64-libs this currently
# (early 2018) expands to about 1900 characters.