aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2021-09-22 14:48:06 +0100
committerJoão Valverde <j@v6e.pt>2021-09-22 16:43:09 +0100
commit9f9afc0e8605b8db03136a6b53905b35be711119 (patch)
treea24643d0b873713b5c6cb5940a806a60b879657f /CMakeLists.txt
parent6921f01250c8722fb925943f41f4647a1cbd02f1 (diff)
CMake: Remove an unnecessary version check
MINGW implies WIN32 which implies CMake >= 3.13. Follow-up to 1dad8190b1ec4ab730de428437f2f6bbbf7ce345.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 841b3ed70b..c23b3037dd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2587,7 +2587,7 @@ endmacro()
macro(executable_link_mingw_unicode _target)
# target_link_options() requires CMake >= 3.13
- if (MINGW AND CMAKE_VERSION VERSION_GREATER "3.12.99")
+ if (MINGW)
target_link_options(${_target} PRIVATE "-municode")
endif()
endmacro()