aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2021-11-07 23:46:40 +0000
committerJoão Valverde <j@v6e.pt>2021-11-14 21:00:59 +0000
commit9df5279af7ac74e8c50f666b4d347572506ea239 (patch)
tree1a10f7c5715497844d9bd8c89839fefbeb1edf87 /CMakeLists.txt
parented8a02af172200c037a3ddf3d63eea9c2f587957 (diff)
dfilter: Remove support for GRegex
PCRE2 is mature, widely used and widely available. Supporting two different RE implementations, one of which is unmaintained, is unnecessary and counter-productive.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 630246d313..77f718bc81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3775,6 +3775,12 @@ configure_file(
add_custom_target(uninstall
COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake)
+if(NOT HAVE_PCRE2)
+ message(WARNING "Building without PCRE2 is not recommended. \
+Regular expression matching will be unavailable."
+ )
+endif()
+
#
# Editor modelines - https://www.wireshark.org/tools/modelines.html
#