aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-07-01 18:01:38 -0700
committerGuy Harris <guy@alum.mit.edu>2014-07-02 01:02:21 +0000
commit98d8dec61f566df6f6dc11accc0f29117bc2bbf3 (patch)
tree47ced5dde6c3c014f4fba2ac9825107bdb6fad8b /CMakeLists.txt
parent096aca67defc82e72daeb45e109d13227cc80eed (diff)
See if this forces version.h to be built.
(It's not being built by the Ubuntu buildboth when it's building the Debian package.) Change-Id: Id7866e13ce72cdda4bb7d5cf0362ba7295ff766b Reviewed-on: https://code.wireshark.org/review/2772 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb874c032a..9b943a4852 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -712,7 +712,7 @@ ADD_CUSTOM_TARGET(
set_target_properties(gitversion PROPERTIES FOLDER "Auxiliary")
ADD_CUSTOM_COMMAND(
- OUTPUT version.h
+ OUTPUT ${CMAKE_BINARY_DIR}/version.h
COMMAND ${PERL_EXECUTABLE}
${CMAKE_CURRENT_SOURCE_DIR}/make-version.pl
${CMAKE_CURRENT_SOURCE_DIR}
@@ -917,7 +917,7 @@ set(SHARK_COMMON_SRC
capture-pcap-util.c
cfile.c
frame_tvbuff.c
- version.h
+ ${CMAKE_BINARY_DIR}/version.h
sync_pipe_write.c
version_info.c
)
@@ -1241,7 +1241,7 @@ if(BUILD_mergecap)
)
set(mergecap_FILES
mergecap.c
- version.h
+ ${CMAKE_BINARY_DIR}/version.h
image/mergecap.rc
)
add_executable(mergecap ${mergecap_FILES})
@@ -1260,7 +1260,7 @@ if(BUILD_reordercap)
)
set(reordercap_FILES
reordercap.c
- version.h
+ ${CMAKE_BINARY_DIR}/version.h
image/reordercap.rc
)
add_executable(reordercap ${reordercap_FILES})
@@ -1343,7 +1343,7 @@ if(BUILD_dumpcap AND PCAP_FOUND)
${NL_LIBRARIES}
)
set(dumpcap_FILES
- version.h
+ ${CMAKE_BINARY_DIR}/version.h
capture_opts.c
capture-pcap-util.c
capture_stop_conditions.c