aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2019-10-10 15:34:46 +0000
committerJoão Valverde <j@v6e.pt>2019-10-10 15:58:41 +0000
commit97cb389a3531269b3c86555156a2bba62ccfd8a5 (patch)
tree16a7b35a0e1a1411fcf11ff3e05af31b2e2c57ae /CMakeLists.txt
parent51fbc7198ef3ebd49c3c491e4a5b3ed72eec278d (diff)
Revert "CMake: Don't install HTML manuals twice"
This reverts commit f1285fcf061669702ca1accd7b2c50ebc8198993. NSIS package is broken with this commit. Change-Id: Ief22a308edad188fa2d5fab79355f19493359fa6 Reviewed-on: https://code.wireshark.org/review/34758 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f354b999f1..f9ae5d57ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1729,8 +1729,42 @@ set(INSTALL_FILES
smi_modules
wka
docbook/ws.css
+ ${CMAKE_BINARY_DIR}/doc/AUTHORS-SHORT
+ ${CMAKE_BINARY_DIR}/doc/androiddump.html
+ ${CMAKE_BINARY_DIR}/doc/udpdump.html
+ ${CMAKE_BINARY_DIR}/doc/capinfos.html
+ ${CMAKE_BINARY_DIR}/doc/captype.html
+ ${CMAKE_BINARY_DIR}/doc/ciscodump.html
+ ${CMAKE_BINARY_DIR}/doc/dftest.html
+ ${CMAKE_BINARY_DIR}/doc/dumpcap.html
+ ${CMAKE_BINARY_DIR}/doc/editcap.html
+ ${CMAKE_BINARY_DIR}/doc/extcap.html
+ ${CMAKE_BINARY_DIR}/doc/mergecap.html
+ ${CMAKE_BINARY_DIR}/doc/randpkt.html
+ ${CMAKE_BINARY_DIR}/doc/randpktdump.html
+ ${CMAKE_BINARY_DIR}/doc/rawshark.html
+ ${CMAKE_BINARY_DIR}/doc/reordercap.html
+ ${CMAKE_BINARY_DIR}/doc/sshdump.html
+ ${CMAKE_BINARY_DIR}/doc/text2pcap.html
+ ${CMAKE_BINARY_DIR}/doc/tshark.html
+ ${CMAKE_BINARY_DIR}/doc/wireshark.html
+ ${CMAKE_BINARY_DIR}/doc/wireshark-filter.html
)
+if(MAXMINDDB_FOUND)
+ list(APPEND INSTALL_FILES ${CMAKE_BINARY_DIR}/doc/mmdbresolve.html)
+endif()
+
+if (BUILD_corbaidl2wrs)
+ list(APPEND INSTALL_FILES ${CMAKE_BINARY_DIR}/doc/idl2wrs.html)
+endif()
+if (BUILD_xxx2deb)
+ list(APPEND INSTALL_FILES
+ ${CMAKE_BINARY_DIR}/doc/asn2deb.html
+ ${CMAKE_BINARY_DIR}/doc/idl2deb.html
+ )
+endif()
+
if(WIN32)
set(TEXTIFY_FILES COPYING NEWS README.windows)
set(TEXTIFY_MD_FILES README.md)
@@ -1972,6 +2006,7 @@ foreach(_install_file ${INSTALL_FILES})
"${_install_file_src}"
"${_output_file}"
DEPENDS
+ docs
"${_install_file}"
)
list(APPEND copy_data_files_depends "${_output_file}")
@@ -2000,6 +2035,7 @@ if(LUA_FOUND AND ENABLE_LUA)
)
endforeach()
endif(LUA_FOUND AND ENABLE_LUA)
+# doc/*.html handled elsewhere.
# Glob patterns relative to the source directory that should be copied to
# ${DATAFILE_DIR} (including directory prefixes)