aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2019-04-19 11:50:08 +0100
committerPeter Wu <peter@lekensteyn.nl>2019-04-19 17:29:11 +0000
commit8c2621754803ae0c0dca92f423c43222c1f61d9e (patch)
treea6cf8fd8e03d1fe04ba20909b950f56d7ca0be52 /CMakeLists.txt
parent3f9579e3f5f84262d0f8c849a0f98220fee8d722 (diff)
CMake: bail out if minimum GLib version is not satisfied
Require glibconfig.h to be found and extract the version from this file, this has been present since the original GLib commit and is still present in the meson build system introduced with 2.53.4. Bug: 15706 Change-Id: I2e938a339d48d6815ed7cc46462735b93418377f Reviewed-on: https://code.wireshark.org/review/32894 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95822cd0a6..d182d43017 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -994,9 +994,8 @@ endmacro()
# The minimum package list
find_package(Git)
-set(GLIB2_MIN_VERSION 2.32.0)
reset_find_package(GLIB2 GLIB2_MAIN_INCLUDE_DIR GLIB2_INTERNAL_INCLUDE_DIR)
-find_package(GLIB2 REQUIRED)
+find_package(GLIB2 "2.32.0" REQUIRED)
include_directories(SYSTEM ${GLIB2_INCLUDE_DIRS})
reset_find_package(GMODULE2)
find_package(GMODULE2)