aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Granados <adrian@intuitibits.com>2022-03-08 16:38:13 -0500
committerA Wireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2022-03-09 08:01:39 +0000
commit8622c92a7549320b5faffb92891c12077f65459d (patch)
tree33f336e769fbedfba71d34273572180545c238b1 /CMakeLists.txt
parentad48c4050d8f489ea3e6d67e9bc57e69b468b329 (diff)
extcap: new interface, wifidump, to capture Wi-Fi frames using a remote SSH host
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 665610a9fe..43b8efd72c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1167,7 +1167,7 @@ if (NOT WIN32)
find_package(M REQUIRED)
endif()
-if(BUILD_sshdump OR BUILD_ciscodump)
+if(BUILD_sshdump OR BUILD_ciscodump OR BUILD_wifidump)
set(ENABLE_LIBSSH ON)
else()
set(ENABLE_LIBSSH OFF)
@@ -1752,7 +1752,7 @@ set_package_properties(LIBXML2 PROPERTIES
set_package_properties(LIBSSH PROPERTIES
DESCRIPTION "Library for implementing SSH clients"
URL "https://www.libssh.org/"
- PURPOSE "extcap remote SSH interfaces (sshdump, ciscodump)"
+ PURPOSE "extcap remote SSH interfaces (sshdump, ciscodump, wifidump)"
)
set_package_properties(LZ4 PROPERTIES
DESCRIPTION "LZ4 is a fast lossless compression algorithm"
@@ -1949,6 +1949,7 @@ if (ASCIIDOCTOR_FOUND)
${CMAKE_BINARY_DIR}/doc/rawshark.html
${CMAKE_BINARY_DIR}/doc/reordercap.html
${CMAKE_BINARY_DIR}/doc/sshdump.html
+ ${CMAKE_BINARY_DIR}/doc/wifidump.html
${CMAKE_BINARY_DIR}/doc/text2pcap.html
${CMAKE_BINARY_DIR}/doc/tshark.html
${CMAKE_BINARY_DIR}/doc/wireshark.html