aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-09-24 09:19:54 +0100
committerJoão Valverde <j@v6e.pt>2017-09-24 12:27:28 +0000
commit69bfcbc67ece916630d212a9cc094694182df4f6 (patch)
tree771734a305a3ef866ca7dfd7811e6d2cee574228 /CMakeLists.txt
parentcf4abe137661c7bd6ac5d1fd194969f2debfcaac (diff)
CMake: Print build flags just before feature summary
Change-Id: I79cc1df1eb04c5ed9bed722f07fdea7db2adcede Reviewed-on: https://code.wireshark.org/review/23674 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 7 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4582bc730f..afbff015ac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1260,12 +1260,6 @@ if(ENABLE_CHECKHF_CONFLICT)
set(ENABLE_CHECK_FILTER 1)
endif()
-string(REPLACE ";" " " _warnings_c_flags "${WS_WARNINGS_C_FLAGS}")
-message(STATUS "C-Flags: ${CMAKE_C_FLAGS} ${_warnings_c_flags}")
-string(REPLACE ";" " " _warnings_cxx_flags "${WS_WARNINGS_CXX_FLAGS}")
-message(STATUS "CXX-Flags: ${CMAKE_CXX_FLAGS} ${_warnings_cxx_flags}")
-message(STATUS "Warnings as errors: ${WERROR_COMMON_FLAGS}")
-
if(APPLE)
#
# We assume that APPLE means macOS so that we have the macOS
@@ -1569,6 +1563,13 @@ set_package_properties(YAPP PROPERTIES
URL "http://search.cpan.org/dist/Parse-Yapp/"
PURPOSE "tpg plugin"
)
+
+string(REPLACE ";" " " _warnings_c_flags "${WS_WARNINGS_C_FLAGS}")
+message(STATUS "C-Flags: ${CMAKE_C_FLAGS} ${_warnings_c_flags}")
+string(REPLACE ";" " " _warnings_cxx_flags "${WS_WARNINGS_CXX_FLAGS}")
+message(STATUS "CXX-Flags: ${CMAKE_CXX_FLAGS} ${_warnings_cxx_flags}")
+message(STATUS "Warnings as errors: ${WERROR_COMMON_FLAGS}")
+
feature_summary(WHAT ALL)
link_directories(