aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-10-13 21:07:33 -0700
committerGuy Harris <guy@alum.mit.edu>2015-10-14 04:07:58 +0000
commit66526f60c495a79a1d784caaca2c1f0d13bb7b11 (patch)
tree656ffd1ee3e610b59328f7acb65ee88c06f3db12 /CMakeLists.txt
parent0596575a87b766eab0f6a8b4593888d6edf3a085 (diff)
Set QT_MULTIMEDIA_LIB if we're using Qt 4 and have QtMultimedia.
Change-Id: Iee13fe86c0d8cacc71ab1cae25f4c735c5fe7b1d Reviewed-on: https://code.wireshark.org/review/10993 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43167708ca..ff9f307f2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -896,6 +896,10 @@ elseif(QT_FOUND)
include_directories(${QT_INCLUDE_DIR})
message(STATUS "Qt includes: ${QT_INCLUDE_DIR}")
message(STATUS "Qt libs: ${QT_LIBRARIES}")
+ if(QT_QTMULTIMEDIA_FOUND)
+ # That's the name autofoo uses
+ set(QT_MULTIMEDIA_LIB 1)
+ endif()
endif()
message(STATUS "C-Flags: ${CMAKE_C_FLAGS}")