aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJörg Mayer <jmayer@loplof.de>2013-04-22 22:32:03 +0000
committerJörg Mayer <jmayer@loplof.de>2013-04-22 22:32:03 +0000
commit4f8cb5fdc3feb8cb3da412c2cf7a753f940e1ca0 (patch)
tree648da7fe4c9877e6949bb977115d51c50e69d48c /CMakeLists.txt
parent2a50c3180032430e6ea6b9f8c98b4d6f6d41fb34 (diff)
Mimic autoconf behavior and enable -Wc++-compat by default.
svn path=/trunk/; revision=48992
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 590d50ee07..cc0eaa98e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -130,6 +130,7 @@ set(WIRESHARK_C_FLAGS
set(WIRESHARK_C_ONLY_FLAGS
# The following are C only, not C++
+ -Wc++-compat
-Wdeclaration-after-statement
-Wno-pointer-sign
-Wold-style-definition
@@ -169,7 +170,6 @@ set(WIRESHARK_EXTRA_C_FLAGS
set(WIRESHARK_EXTRA_C_ONLY_FLAGS
# The following are C only, not C++
-Wbad-function-cast
- -Wc++-compat
-Wjump-misses-init
# GLib blocks this for now.
-Wstrict-prototypes