aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2021-12-31 10:15:28 -0800
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2022-01-01 08:09:12 +0000
commit4e417b8e7cabe83a01921f4df2281ea2d5a2a507 (patch)
tree33a259ff64daeb9c4fe36731ef4e0bbbc3800dc7 /CMakeLists.txt
parent67f05835cac0a26636a7e04739a4cc0dd225c077 (diff)
Windows: UTF-8 harder.
Set the process code page in wireshark.exe.manifest to UTF-8 as described at https://docs.microsoft.com/en-us/windows/apps/design/globalizing/use-utf8-code-page Make sure each of our command line resource files includes our main manifest. Rename wiretap.rc to libwiretap.rc to match our other libraries.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 35233586de..d3391da87d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1698,12 +1698,12 @@ set(DOXYGEN_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
set(CFG_OUT_FILES
doxygen.cfg
- image/libwireshark.rc
- image/wireshark.rc
image/dumpcap.rc
+ image/libwireshark.rc
+ image/libwiretap.rc
image/libwsutil.rc
- image/wiretap.rc
image/wireshark.exe.manifest
+ image/wireshark.rc
packaging/macosx/Info.plist
packaging/macosx/dmgbuild-settings.py
packaging/macosx/osx-app.sh