aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNardi Ivan <nardi.ivan@gmail.com>2021-06-28 13:58:36 +0200
committerAndersBroman <a.broman58@gmail.com>2021-09-13 15:13:10 +0000
commit3cb302f05b0b8e16b97d4ada5c3027641d9b4a3c (patch)
tree37e75b796fb41917362ef4d4752ffdde0c897fbb /CMakeLists.txt
parenta7a7849259cff96fc3d585e3067079cea856bfc7 (diff)
HTTP2, QUIC: fix "Follow Stream"
"Follow Stream" functionality assumes that all data in a single packet belongs to the same stream. That is not true for HTTP2 and QUIC, where we end up having data from unrelated streams. Filter out the unwanted data directly in the protocol dissector code with a custom `tap_handler` (as TCP already does). Close #16093
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 22bfdf21bb..8e0ece8e49 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3529,6 +3529,7 @@ set(_test_group_list
suite_fileformats
suite_follow
suite_follow_dccp
+ suite_follow_multistream
suite_io
suite_mergecap
suite_netperfmeter