aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2021-12-30 01:05:57 +0000
committerA Wireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2022-01-03 15:55:06 +0000
commit119473eab355e5d029e7ad7830373ac69b507adf (patch)
tree95925e84253166d374621a830ca57b789d336e56 /CMakeLists.txt
parent60dd63892a925e2f0648a20b1fbf4c876b5cf03e (diff)
CMake: Use more consistent naming for options
Having some options use DISABLE_ and others ENABLE_ is inconsistent and difficult to remember. Use ENABLE_ instead consistently. Frame-larger-than remains an exception.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3391da87d..3b33d7ae79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -464,8 +464,8 @@ set_property(DIRECTORY
PROPERTY COMPILE_DEFINITIONS
"G_DISABLE_DEPRECATED"
"G_DISABLE_SINGLE_INCLUDES"
- $<$<OR:$<BOOL:${DISABLE_ASSERT}>,$<CONFIG:Release>>:WS_DISABLE_ASSERT>
- $<$<OR:$<BOOL:${DISABLE_DEBUG}>,$<CONFIG:Release>>:WS_DISABLE_DEBUG>
+ $<$<OR:$<NOT:$<BOOL:${ENABLE_ASSERT}>>,$<CONFIG:Release>>:WS_DISABLE_ASSERT>
+ $<$<OR:$<NOT:$<BOOL:${ENABLE_DEBUG}>>,$<CONFIG:Release>>:WS_DISABLE_DEBUG>
)
if(WIN32)
@@ -987,7 +987,7 @@ if(MSVC)
endif()
set(WERROR_COMMON_FLAGS "")
-if(NOT DISABLE_WERROR AND NOT ENABLE_EXTRA_COMPILER_WARNINGS)
+if(ENABLE_WERROR AND NOT ENABLE_EXTRA_COMPILER_WARNINGS)
if(CMAKE_C_COMPILER_ID MATCHES "MSVC")
set(WERROR_COMMON_FLAGS "/WX")
else()