aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2017-10-20 16:10:34 -0700
committerAnders Broman <a.broman58@gmail.com>2017-10-21 08:23:45 +0000
commit0d9b8eaf088628255e64343462ac0e2e90c66c67 (patch)
treef63f63af6379947eabae6b2746a6d9eb9816d6ba /CMakeLists.txt
parentb289699ace2075c934f7009dea307156f9296071 (diff)
Warn the developer if we're building with GTK+.
Move The Slowest Migration In The History Of Ever a little further along. Change-Id: Ib8b49708e7036dd412a7ffc8660ded9f681374c0 Reviewed-on: https://code.wireshark.org/review/24006 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 03ee1caab7..b25529cd1a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1136,6 +1136,7 @@ endif()
# No matter which version of GTK is present
if(GTK2_FOUND OR GTK3_FOUND)
+ message(WARNING "The GTK+ UI is deprecated and will be removed in a future release.")
set(GTK_FOUND ON)
endif()