aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2020-05-27 15:00:46 -0700
committerGuy Harris <gharris@sonic.net>2020-05-28 04:59:56 +0000
commit029051d7e91458ef202607408c99872c3b299445 (patch)
tree33c2e10ad1f2030977a01e58ebf6089faea53f14 /CMakeLists.txt
parenta584fd9fb60c6e45b1a3773aba38627f16f58acb (diff)
CMake: Add a MIN_MACOS_VERSION check for Qt 5.15.
According to https://doc.qt.io/qt-5/supported-platforms.html, Qt 5.15 supports macOS 10.13 - 10.15. Change-Id: Iecd9b6f10d6b968ad145d247e934fddec25658f7 Reviewed-on: https://code.wireshark.org/review/37330 Petri-Dish: Guy Harris <gharris@sonic.net> Tested-by: Petri Dish Buildbot Reviewed-by: Guy Harris <gharris@sonic.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 559a1522dc..57d584595e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1276,9 +1276,12 @@ if (QT_FOUND)
find_program(DMGBUILD_EXECUTABLE dmgbuild
DOC "Path to the dmgbuild utility"
)
+ # https://doc.qt.io/qt-5/supported-platforms.html
# https://doc.qt.io/qt-5.11/supported-platforms-and-configurations.html
# CMake < 3.7 doesn't support VERSION_GREATER_EQUAL.
- if(Qt5Widgets_VERSION VERSION_GREATER "5.11.999")
+ if(Qt5Widgets_VERSION VERSION_GREATER "5.14.999")
+ set(MIN_MACOS_VERSION 10.13)
+ elseif(Qt5Widgets_VERSION VERSION_GREATER "5.11.999")
set(MIN_MACOS_VERSION 10.12)
elseif(Qt5Widgets_VERSION VERSION_GREATER "5.9.999")
set(MIN_MACOS_VERSION 10.11)