summaryrefslogtreecommitdiffstats
path: root/src/host/layer23/src/mobile/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/host/layer23/src/mobile/Makefile.am')
-rw-r--r--src/host/layer23/src/mobile/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/host/layer23/src/mobile/Makefile.am b/src/host/layer23/src/mobile/Makefile.am
index 47870e56..4e80e4ea 100644
--- a/src/host/layer23/src/mobile/Makefile.am
+++ b/src/host/layer23/src/mobile/Makefile.am
@@ -12,4 +12,10 @@ bin_PROGRAMS = mobile
mobile_SOURCES = main.c app_mobile.c
mobile_LDADD = libmobile.a $(LDADD)
-
+# lua support
+if BUILD_LUA
+AM_CPPFLAGS += -DWITH_LUA=1
+libmobile_a_SOURCES += script_lua.c
+else
+libmobile_a_SOURCES += script_nolua.c
+endif