summaryrefslogtreecommitdiffstats
path: root/src/host/layer2/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/host/layer2/configure.ac')
-rw-r--r--src/host/layer2/configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/host/layer2/configure.ac b/src/host/layer2/configure.ac
new file mode 100644
index 00000000..72ed2f82
--- /dev/null
+++ b/src/host/layer2/configure.ac
@@ -0,0 +1,24 @@
+dnl Process this file with autoconf to produce a configure script
+AC_INIT
+
+AM_INIT_AUTOMAKE(layer2, 0.0.0)
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+dnl checks for header files
+AC_HEADER_STDC
+
+dnl Checks for typedefs, structures and compiler characteristics
+
+AC_OUTPUT(
+ src/Makefile
+ include/Makefile
+ include/osmocom/Makefile
+ Makefile)