summaryrefslogtreecommitdiffstats
path: root/src/host/gsmmap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/host/gsmmap/Makefile.am')
-rw-r--r--src/host/gsmmap/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/host/gsmmap/Makefile.am b/src/host/gsmmap/Makefile.am
index d866d02e..e71b887c 100644
--- a/src/host/gsmmap/Makefile.am
+++ b/src/host/gsmmap/Makefile.am
@@ -7,12 +7,11 @@ $(top_srcdir)/.version:
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
-INCLUDES = $(all_includes) -I$(top_srcdir)/include
-AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS)
+INCLUDES = $(all_includes) -I../layer23/include -DHOST_BUILD
+AM_CFLAGS=-Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS)
sbin_PROGRAMS = gsmmap
-INCLUDES += -I../layer23/include -DHOST_BUILD
gsmmap_SOURCES = gsmmap.c geo.c locate.c log.c ../layer23/src/common/sysinfo.c ../layer23/src/common/networks.c
-gsmmap_LDADD = $(LIBOSMOCORE_LIBS) -lm
+gsmmap_LDADD = $(LIBOSMOGSM_LIBS) $(LIBOSMOCORE_LIBS) -lm