summaryrefslogtreecommitdiffstats
path: root/src/host/layer23/src/common/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2018-10-03 06:34:05 +0700
committerVadim Yanitskiy <axilirator@gmail.com>2018-11-21 11:03:10 +0700
commit33afaa9c6f8360b843ac4de0567f7662cd89d5c3 (patch)
treebad1309d2d4bdfd1029be0bfaf8adc4401cda155 /src/host/layer23/src/common/Makefile.am
parentc8de8cb1e126a18c0269571fba38310589dd9273 (diff)
layer23/common: introduce L23SAP API for L1CTL
Having a separate abstraction layer between both L1CTL interface and the upper layers would allow to keep the L1CTL implementation clean from GSMTAP / LAPDm / measurement specific stuff. Change-Id: I22d7932ddc03c692f2616726ced53b6e8eef822d
Diffstat (limited to 'src/host/layer23/src/common/Makefile.am')
-rw-r--r--src/host/layer23/src/common/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/host/layer23/src/common/Makefile.am b/src/host/layer23/src/common/Makefile.am
index b76094c6..e1b7b448 100644
--- a/src/host/layer23/src/common/Makefile.am
+++ b/src/host/layer23/src/common/Makefile.am
@@ -3,4 +3,4 @@ AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBGPS_CFLAGS)
noinst_LIBRARIES = liblayer23.a
liblayer23_a_SOURCES = l1ctl.c l1l2_interface.c sap_interface.c \
- logging.c networks.c sim.c sysinfo.c gps.c l1ctl_lapdm_glue.c utils.c
+ logging.c networks.c sim.c sysinfo.c gps.c l1ctl_lapdm_glue.c utils.c l23sap.c