summaryrefslogtreecommitdiffstats
path: root/src/host/layer23/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-03-03 14:24:05 +0100
committerHarald Welte <laforge@gnumonks.org>2010-03-03 14:25:21 +0100
commitd4e118a7a059a9d675d0d8a8ea75fdc88f43afb7 (patch)
treeb685489a7e6f68f829e30b58602ce622cd5adc0e /src/host/layer23/configure.ac
parent9c64d2869f6b389478377d748f318206b3a8fe3f (diff)
Rename 'layer2' program to 'layer23' program
Diffstat (limited to 'src/host/layer23/configure.ac')
-rw-r--r--src/host/layer23/configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/host/layer23/configure.ac b/src/host/layer23/configure.ac
new file mode 100644
index 00000000..177d9681
--- /dev/null
+++ b/src/host/layer23/configure.ac
@@ -0,0 +1,27 @@
+dnl Process this file with autoconf to produce a configure script
+AC_INIT
+
+AM_INIT_AUTOMAKE(layer23, 0.0.0)
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+dnl checks for libraries
+PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore)
+
+dnl checks for header files
+AC_HEADER_STDC
+
+dnl Checks for typedefs, structures and compiler characteristics
+
+AC_OUTPUT(
+ src/Makefile
+ include/Makefile
+ include/osmocom/Makefile
+ Makefile)