summaryrefslogtreecommitdiffstats
path: root/src/host/layer23/configure.ac
diff options
context:
space:
mode:
authorVadim Yanitskiy <vyanitskiy@sysmocom.de>2022-11-05 19:10:55 +0700
committerVadim Yanitskiy <vyanitskiy@sysmocom.de>2022-11-05 19:10:55 +0700
commit6ba147556baee4e80ced886fc8ee1c18fb77ed7b (patch)
treebfd33802e8ec27e5a149d48d54851b838f177c65 /src/host/layer23/configure.ac
parent671ac36b112dea90662e91d6009ab30679b430dc (diff)
layer23: add -Werror={implicit-int,int-conversion,old-style-definition}
Diffstat (limited to 'src/host/layer23/configure.ac')
-rw-r--r--src/host/layer23/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/host/layer23/configure.ac b/src/host/layer23/configure.ac
index 3ce9ead1..2817ed1d 100644
--- a/src/host/layer23/configure.ac
+++ b/src/host/layer23/configure.ac
@@ -32,6 +32,7 @@ AC_ARG_ENABLE(werror,
if test x"$werror" = x"yes"
then
WERROR_FLAGS="-Werror"
+ WERROR_FLAGS+=" -Werror=implicit-int -Werror=int-conversion -Werror=old-style-definition"
WERROR_FLAGS+=" -Wno-error=deprecated -Wno-error=deprecated-declarations"
WERROR_FLAGS+=" -Wno-error=cpp" # "#warning"
CFLAGS="$CFLAGS $WERROR_FLAGS"