aboutsummaryrefslogtreecommitdiffstats
path: root/src/mate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mate/Makefile.am')
-rw-r--r--src/mate/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/mate/Makefile.am b/src/mate/Makefile.am
new file mode 100644
index 0000000..b32cb7e
--- /dev/null
+++ b/src/mate/Makefile.am
@@ -0,0 +1,29 @@
+AM_CPPFLAGS = -Wall -Wextra -Wmissing-prototypes -g $(all_includes)
+
+bin_PROGRAMS = \
+ matesimulator
+
+matesimulator_SOURCES = \
+ matesimulator.c
+
+matesimulator_LDADD = \
+ $(COMMON_LA) \
+ $(top_builddir)/src/liboptions/liboptions.a \
+ $(top_builddir)/src/libdebug/libdebug.a \
+ $(top_builddir)/src/libwave/libwave.a \
+ $(top_builddir)/src/libsample/libsample.a \
+ $(top_builddir)/src/liblogging/liblogging.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOCC_LIBS) \
+ -lm
+
+if HAVE_ALSA
+matesimulator_LDADD += \
+ $(top_builddir)/src/libsound/libsound.a \
+ $(ALSA_LIBS)
+endif
+
+if HAVE_ALSA
+AM_CPPFLAGS += -DHAVE_ALSA
+endif
+