aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Tsou <tom.tsou@ettus.com>2015-08-21 18:28:52 -0700
committerTom Tsou <tom.tsou@ettus.com>2015-08-21 19:20:32 -0700
commitc312905f43bb120450c33d9a80bc35771d598fc6 (patch)
tree2d559fd935695460265740f14fece91d83f18c18 /configure.ac
parentc4eab8795f79910c72f2153900d5af1e3feda813 (diff)
uhd: Add version 3.9.0 support
New functionality includes B200-mini device support and updated timing values to match FPGA changes. Signed-off-by: Tom Tsou <tom.tsou@ettus.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0a64dee..0e35e36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,8 +97,11 @@ AS_IF([test "x$with_usrp1" = "xyes"], [
])
AS_IF([test "x$with_usrp1" != "xyes"],[
- PKG_CHECK_MODULES(UHD, uhd >= 003.004.000)
- AC_DEFINE(USE_UHD, 1, Define to 1 if using UHD)
+ PKG_CHECK_MODULES(UHD, uhd >= 003.009,
+ [AC_DEFINE(USE_UHD_3_9, 1, UHD version 3.9.0 or higher)],
+ [PKG_CHECK_MODULES(UHD, uhd >= 003.004.000)]
+ )
+ AC_DEFINE(USE_UHD, 1, All UHD versions)
])
AS_IF([test "x$with_singledb" = "xyes"], [