aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/device/Makefile.am
diff options
context:
space:
mode:
authorEric Wild <ewild@sysmocom.de>2020-03-24 17:19:27 +0100
committerEric <ewild@sysmocom.de>2020-08-25 01:00:03 +0200
commit1e17c4fb0a77dcee49a7cd566dca7e8f48f6d8e7 (patch)
tree9e680f91408ff7741fe62d7689ad420c1f48648a /Transceiver52M/device/Makefile.am
parentf9a2f4427277f36b9459cd349512f6ca3230fe9c (diff)
osmo-trx-ipc
This adds a IPC backend that uses shared memory interface to communicate with (proprietary) devices. Requires config file option dev-args ipc_msock=/path/to/socket to specify the master socket the ipc backend should connect to. If UHD is avaialble the ipc-driver-test tool can be used to test the backend with a uhd device, this was so far only tested with a b2xx. Change-Id: Ice63d3499026293ade8aad675ff7a883bcdd5756
Diffstat (limited to 'Transceiver52M/device/Makefile.am')
-rw-r--r--Transceiver52M/device/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Transceiver52M/device/Makefile.am b/Transceiver52M/device/Makefile.am
index 369e877..93ba7e3 100644
--- a/Transceiver52M/device/Makefile.am
+++ b/Transceiver52M/device/Makefile.am
@@ -2,6 +2,10 @@ include $(top_srcdir)/Makefile.common
SUBDIRS = common
+if DEVICE_IPC
+SUBDIRS += ipc
+endif
+
if DEVICE_USRP1
SUBDIRS += usrp1
endif