aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/channel/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-01-14 15:55:42 +0100
committerHarald Welte <laforge@gnumonks.org>2011-02-11 16:26:31 +0100
commitf338a03b0cc85ca20bfe8e1ebe3b98e86bcef3c1 (patch)
tree687ce70060164c999855bdf734a08c91a6c5b5f1 /openbsc/tests/channel/Makefile.am
parentf3956cbb20ce92c3df20169a8a3c625759290696 (diff)
[BSC] Move the BTS-type specific code from bcs_init.c to bts_*.c
bsc_init.c was a big mess even only for two supported BTS models, so before adding more BTS types, this needs a cleanup. All the BTS specific code from bsc_init.c has now moved into bts_{siemens_bs11,ipaccess_nanobts}.c This has required that input_event() and nm_state_event() get both converted to proper libosmocore signals instead of referencing external symbols.
Diffstat (limited to 'openbsc/tests/channel/Makefile.am')
-rw-r--r--openbsc/tests/channel/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/openbsc/tests/channel/Makefile.am b/openbsc/tests/channel/Makefile.am
index 772965953..8593b5a13 100644
--- a/openbsc/tests/channel/Makefile.am
+++ b/openbsc/tests/channel/Makefile.am
@@ -9,6 +9,7 @@ channel_test_SOURCES = channel_test.c \
$(top_srcdir)/src/gsm_subscriber.c \
$(top_srcdir)/src/debug.c \
$(top_srcdir)/src/gsm_data.c \
+ $(top_srcdir)/src/abis_nm.c \
$(top_srcdir)/src/bts_ipaccess_nanobts.c \
$(top_srcdir)/src/bts_siemens_bs11.c
channel_test_LDADD = -ldl -ldbi $(LIBOSMOCORE_LIBS)