aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/tests/channel/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-06-30 21:41:08 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2011-06-30 21:41:08 +0200
commit3d331c0062bb0c9694dbd4d1eab7adc58138c3ae (patch)
treefa8b6063c023952d0e0bd1d4de7dc53ffc5de68f /openbsc/tests/channel/Makefile.am
parentf5bbb1eb7123c5b1281254f6d75ee5bf00874619 (diff)
misc: Link to libosmogsm after adding our static libraries
GCC 4.6.0 and LD.BFD 2.21 on ARM somehow fail to resolve the dbi symbols when we have the library in front of the static libraries, move them to the back. Without this patch the tlv_def_patch symbol and the gsm48_construct_ra.
Diffstat (limited to 'openbsc/tests/channel/Makefile.am')
-rw-r--r--openbsc/tests/channel/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/openbsc/tests/channel/Makefile.am b/openbsc/tests/channel/Makefile.am
index a9ce3ea35..404ab3225 100644
--- a/openbsc/tests/channel/Makefile.am
+++ b/openbsc/tests/channel/Makefile.am
@@ -4,7 +4,7 @@ AM_CFLAGS=-Wall -ggdb3 $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS)
noinst_PROGRAMS = channel_test
channel_test_SOURCES = channel_test.c
-channel_test_LDADD = -ldl $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) \
+channel_test_LDADD = -ldl $(LIBOSMOCORE_LIBS) \
$(top_builddir)/src/libcommon/libcommon.a \
$(top_builddir)/src/libbsc/libbsc.a \
- $(top_builddir)/src/libmsc/libmsc.a -ldbi
+ $(top_builddir)/src/libmsc/libmsc.a -ldbi $(LIBOSMOGSM_LIBS)