aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2015-11-30 18:06:50 +0100
committerJacob Erlbeck <jerlbeck@sysmocom.de>2015-12-15 15:19:42 +0100
commit409f980a180ad8977717cbb5ec412990a0ecbfb0 (patch)
tree2643bda3ef63f9e7787a0845f75a80ac4b292c55 /src/Makefile.am
parent14e00f8f66faf0c1f551d1d5e4527c51177d6dc8 (diff)
edge: Add GprsCodingScheme class
Currently the coding scheme is checked and compared at different places which makes in cumbersome to extend it for EGPRS. This class encapsules the coding scheme and provides required meta information like sizes as well as helper methods. Sponsored-by: On-Waves ehf
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 12170757..6428bef1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -56,7 +56,8 @@ libgprs_la_SOURCES = \
llc.cpp \
rlc.cpp \
osmobts_sock.cpp \
- gprs_codel.c
+ gprs_codel.c \
+ gprs_coding_scheme.cpp
bin_PROGRAMS = \
osmo-pcu
@@ -94,7 +95,8 @@ noinst_HEADERS = \
llc.h \
pcu_utils.h \
cxx_linuxlist.h \
- gprs_codel.h
+ gprs_codel.h \
+ gprs_coding_scheme.h
osmo_pcu_SOURCES = pcu_main.cpp