aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2021-05-26 13:17:01 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2021-07-01 13:09:20 +0200
commitdeed90dd0030e6ea32ad4d74386cd91fc2f67436 (patch)
treecc995c7d33fc54bde068ac19c5e092f9780f09b2 /src/Makefile.am
parent4f67a9bf4610c9e948f0d81f3b039f36675180a3 (diff)
WIP: Support ANR procedures on MS with active TBFpespin/anrnext
TODO: * General clean up * Find out and fix why MS not resetting Neighbour List to BA(GPRS) when empty NC_Frequency_List is sent in Packet Measurement Order. * Fix MS most of the time not sending Neighbour report for cells not present in SI2, probably due to waiting not enough time (increasing NC_REPORTING_PERIOD_T may help, but then problem in previous point above may show up more). Also maybe waiting for several reports before continuing may also help. * Configurable/dynamic chunk list size currently hardcoded to 5. Improvements/optimizations: * Use FREQUENCY_DIFF in Add_Frequency for NC_Frequency_List to make it smaller and hence require less PAcketMeasurementOrder messages. * Support Enchanced Packet Report message (need to signal support for it too). Related: SYS#5303 Change-Id: I051d4fa90fe4ccc44ea691f8a3a487e97868e52c
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8070fda3..699a1800 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -62,6 +62,8 @@ libgprs_la_SOURCES = \
tbf_ul.cpp \
tbf_dl.cpp \
bts.cpp \
+ bts_anr_fsm.c \
+ ms_anr_fsm.c \
pdch.cpp \
pdch_ul_controller.c \
encoding.cpp \
@@ -101,6 +103,8 @@ noinst_HEADERS = \
tbf_ul.h \
tbf_dl.h \
bts.h \
+ bts_anr_fsm.h \
+ ms_anr_fsm.h \
pdch.h \
pdch_ul_controller.h \
encoding.h \