aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-05-22 13:51:58 +0200
committerOliver Smith <osmith@sysmocom.de>2019-05-29 12:14:18 +0200
commita558ad426951f6f536c4bc7bef302afbd3573ce6 (patch)
treebb49b27f33e44dfbd9a99c9e11b405da67f5bbae /debian/rules
parenteb64d43922f48901ea4fc872b5c2d65b9e334221 (diff)
debian: create -doc subpackage with pdf manuals
I have verified, that the resulting debian packages build in my own OBS namespace (see the -doc packages): https://download.opensuse.org/repositories/home:/osmith42/Debian_9.0/all/ https://build.opensuse.org/project/show/home:osmith42 Depends: Ib7251cca9116151e473798879375cd5eb48ff3ad (osmo-ci) Related: OS#3899 Change-Id: I9f2e7cfd93ee0b13d064c606a20378c1ea01400e
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 712dd756..2e4284a8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,4 +24,8 @@ override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
override_dh_auto_configure:
- dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system
+ dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
+
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf