aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2016-04-01 19:21:16 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2016-04-01 19:26:09 +0200
commit97e48a3252d75e714bd989504095fb197fbe832e (patch)
treed22ff18035993c54fbd056a647581de93f216e82 /debian/rules
parent63d33ad2d79683fab33542570e20d082bb66476c (diff)
debian: Initial debian packaging
Add initial debian package for plain osmo-pcu (without the sysmoBTS supporot).
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..7623f748
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
+#export DH_VERBOSE=1
+export DEB_BUILD_HARDENING=1
+
+
+%:
+ dh $@ --with=systemd --with autoreconf --fail-missing
+
+override_dh_strip:
+ dh_strip --dbg-package=osmo-pcu-dbg
+
+override_dh_autoreconf:
+ echo $(VERSION) > .tarball-version
+ dh_autoreconf