aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 7 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 6f20b3e..a1b7e18 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,12 +10,15 @@ VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
override_dh_strip:
- dh_strip --dbg-package=libosmo-ranap-dbg
- dh_strip --dbg-package=osmo-hnbgw
+ dh_strip -plibosmo-hnbap0 --dbg-package=libosmo-hnbap-dbg
+ dh_strip -plibosmo-ranap7 --dbg-package=libosmo-ranap-dbg
+ dh_strip -plibosmo-rua0 --dbg-package=libosmo-rua-dbg
+ dh_strip -plibosmo-sabp1 --dbg-package=libosmo-sabp-dbg
# Print test results in case of a failure
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
-override_dh_auto_configure:
- dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf