aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2016-01-04 18:03:31 +0100
committerNeels Hofmeyr <neels@hofmeyr.de>2016-01-04 18:11:19 +0100
commitc04a96c476e8ef87932b93265fb197b9ff45b38a (patch)
tree5e935e72a4d8159e233eeefd1668a424019fd37a /src/Makefile.am
parent16c97669bdc43f99b72233f698f36822f7d21adf (diff)
move asn1 headers to include/ dir (5/5)
Do all remaining changes necessary for a working build. Add Makefile.am files in include/... subdirs. Remove noinst_HEADERS directives from src/*/Makefile.am, but keep the headers list to feed to move-asn1-header-files.sh. Adjust all #includes in src/*_common.h and elsewhere. In hnbap_common.h, separate the ASN.1 "primitive" headers from the others, and include them without a subdir path, as before.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b30b17f..0887b40 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,7 +15,7 @@ ranap_encoder.c ranap_decoder.c ranap_ies_defs.h: $(ASN1_ROOT)/ranap/RANAP-PDU-C
$(ASN1TOSTRUCT) -p RANAP_ -f $<
-AM_CFLAGS = $(OSMOCORE_CFLAGS) $(OSMOVTY_CFLAGS) $(OSMOGSM_CFLAGS) $(OSMONETIF_CFLAGS) $(ASN1C_CFLAGS) $(OSMOSIGTRAN_CFLAGS) -Ihnbap/
+AM_CFLAGS = $(OSMOCORE_CFLAGS) $(OSMOVTY_CFLAGS) $(OSMOGSM_CFLAGS) $(OSMONETIF_CFLAGS) $(ASN1C_CFLAGS) $(OSMOSIGTRAN_CFLAGS) -I../include
COMMON_LDADD = -lsctp
# build the shared RANAP library