aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2016-01-04 15:23:09 +0100
committerNeels Hofmeyr <neels@hofmeyr.de>2016-01-04 18:09:37 +0100
commit5aabad1380bee7b1454aae8bca7db735fd41a2f3 (patch)
treeefebc95c00b24a97ba16566d87591c8e46e8d696 /src/Makefile.am
parent216ac210bfb0e540545ae22faa3da7ee44ccdd28 (diff)
move asn1 headers to include/ dir (1/5)
Add move-asn1-header-files.sh to do header file moving and sed'ding the include statements. The file moving part is disabled until a later commit, to make reading the diffs easier. Call shell script from src/{hnbap,ranap,rua}/Makefile.am regen targets. Add convenience regen target to src/Makefile.am, calling regen in the three subdirs. This change is split over several commits to ease diff reading. Subsequent commits show, in steps: - the "unmoved" effect of sed, - header moves, - adjust build system and include statements.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c6bb440..b30b17f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -50,3 +50,11 @@ osmo_hnbgw_LDADD = $(OSMOCORE_LIBS) $(OSMOVTY_LIBS) $(OSMOGSM_LIBS) \
$(ASN1C_LIBS) $(OSMOSIGTRAN_LIBS) $(COMMON_LDADD) \
hnbap/libosmo-asn1-hnbap.a rua/libosmo-asn1-rua.a \
libosmo-ranap.la
+
+
+regen: regenerate-from-asn1-source
+
+regenerate-from-asn1-source:
+ make -C hnbap regen
+ make -C ranap regen
+ make -C rua regen