aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2015-04-04 13:53:45 +0200
committerSylvain Munaut <tnt@246tNt.com>2015-04-04 13:54:30 +0200
commitab449343f9fe62ddc5de16bb535987308c26a916 (patch)
tree3580321b59c046913b4d9315b93e614e6a757ead /src/Makefile.am
parenta23f3d3243cb99d94a3a61a8c01eb06179c2a557 (diff)
misc: Add an utility to modulate a RACH burst
The output is only 1sps and needs to be filtered by an RRC filter (0.35) before transmission. Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a89e065..08f14ff 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,13 +3,18 @@ SUBDIRS = codec l1 sdr
AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMODSP_CFLAGS)
-bin_PROGRAMS = gmr1_rx gmr1_gen_mat gmr1_ambe_decode
+bin_PROGRAMS = gmr1_rx gmr1_rach_gen gmr1_gen_mat gmr1_ambe_decode
gmr1_rx_SOURCES = gmr1_rx.c gsmtap.c
gmr1_rx_LDADD = $(top_builddir)/src/l1/libgmr1-l1.a \
$(top_builddir)/src/sdr/libgmr1-sdr.a \
$(LIBOSMOCORE_LIBS) $(LIBOSMODSP_LIBS) $(FFTW3F_LIBS)
+gmr1_rach_gen_SOURCES = gmr1_rach_gen.c
+gmr1_rach_gen_LDADD = $(top_builddir)/src/l1/libgmr1-l1.a \
+ $(top_builddir)/src/sdr/libgmr1-sdr.a \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMODSP_LIBS) $(FFTW3F_LIBS)
+
gmr1_gen_mat_SOURCES = gmr1_gen_mat.c
gmr1_gen_mat_LDADD = $(top_builddir)/src/l1/libgmr1-l1.a \
$(LIBOSMOCORE_LIBS)