aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 11 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index eab673c..6962ad3 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
# Process this file with autoconf to produce a configure script.
-AC_INIT(openggsn, 0.52, jj@openggsn.org)
+AC_INIT(openggsn, 0.60, jj@openggsn.org)
AC_CONFIG_SRCDIR([gtp/gtp.c])
AM_CONFIG_HEADER([config.h])
#AC_CONFIG_HEADER([config.h])
@@ -17,14 +17,19 @@ AC_PROG_RANLIB
AC_PROG_LIBTOOL
AM_PROG_LIBTOOL
+AC_ARG_ENABLE(static-exec,
+ [ --enable-static-exec Enable static linking of executables],
+ [ EXEC_LDFLAGS="-all-static"])
+
+AC_SUBST(EXEC_LDFLAGS)
# Checks for libraries.
# FIXME: Replace `main' with a function in `-le':
-AC_CHECK_LIB([e], [main])
+#AC_CHECK_LIB([e], [main])
# FIXME: Replace `main' with a function in `-lgtp':
-AC_CHECK_LIB([gtp], [main])
+#AC_CHECK_LIB([gtp], [main])
# FIXME: Replace `main' with a function in `-links':
-AC_CHECK_LIB([inks], [main])
+#AC_CHECK_LIB([inks], [main])
# Checks for header files.
AC_HEADER_STDC
@@ -53,5 +58,6 @@ AC_CONFIG_FILES([Makefile
po/Makefile
sgsnemu/Makefile
src/Makefile
- tests/Makefile])
+ tests/Makefile
+ openggsn.spec])
AC_OUTPUT