aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2022-11-03 22:07:39 +0100
committerOliver Smith <osmith@sysmocom.de>2022-11-07 14:43:53 +0100
commit20419bdf55a205de1c16e69bbb618264a1473662 (patch)
tree0e3e7be7c43a166a4a777989d09e3d9d9385ea03 /configure.ac
parente443318da4b3c02522e8221c6d7f43bf2a44df8f (diff)
doxygen API documentation for libosmo-e1d
If we actually expect 3rd party applications to use libosmo-e1d to talk to osmo-e1d, we'd better add some basic documentation on how this API shall be used. Change-Id: Ib4a97045bca276fbd3892f801898a436de7dc39b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index be8a094..2cf5a9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,6 +136,14 @@ AC_MSG_CHECKING([whether to enable VTY/CTRL tests])
AC_MSG_RESULT([$enable_ext_tests])
AM_CONDITIONAL(ENABLE_EXT_TESTS, test "x$enable_ext_tests" = "xyes")
+AC_ARG_ENABLE(doxygen,
+ [AS_HELP_STRING(
+ [--disable-doxygen],
+ [Disable generation of documentation using doxygen],
+ )],
+ [doxygen=$enableval], [doxygen="yes"])
+AC_PATH_PROG(DOXYGEN,doxygen,false)
+AM_CONDITIONAL(HAVE_DOXYGEN, test $DOXYGEN != false && test "x$doxygen" = "xyes")
# https://www.freedesktop.org/software/systemd/man/daemon.html
@@ -156,6 +164,7 @@ AM_CONDITIONAL([HAVE_SYSTEMD], [test "x$with_systemdsystemunitdir" != "xno"])
AC_OUTPUT(
Makefile
+ Doxyfile
contrib/Makefile
contrib/systemd/Makefile
contrib/osmo-e1d.spec