aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-04-05 14:08:11 +0200
committerHarald Welte <laforge@gnumonks.org>2019-05-31 14:23:59 +0000
commite05279a2965e8f2d4e87b0d29a9c8a3c610aa447 (patch)
tree995b107767d3c7919fbe3dde117fba611c346694 /debian/rules
parent5abae93dadf37a2b4876fc899463185fb04d561c (diff)
debian: create -doc subpackage with pdf manuals
I have verified, that the resulting debian packages build in my own OBS namespace (see the -doc packages): https://download.opensuse.org/repositories/home:/osmith42/Debian_9.0/all/ https://build.opensuse.org/project/show/home:osmith42 Depends: Ib7251cca9116151e473798879375cd5eb48ff3ad (osmo-ci) Related: OS#3899 Change-Id: I6d7a182d0a668693a5014aca0edc50ada9ac0d0f
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 27de11b8..94bed0ea 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ override_dh_strip:
dh_strip --package=osmo-bts-trx --dbg-package=osmo-bts-trx-dbg
override_dh_auto_configure:
- dh_auto_configure -- --enable-trx --with-systemdsystemunitdir=/lib/systemd/system
+ dh_auto_configure -- --enable-trx --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
override_dh_clean:
dh_clean
@@ -26,3 +26,7 @@ override_dh_clean:
# Print test results in case of a failure
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf