aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2016-12-21 18:20:22 +0100
committerMax <msuraev@sysmocom.de>2016-12-22 15:11:05 +0100
commitc2ecca6b0496127709dcd3afa9d366085d8bec97 (patch)
treecef45df6e9a318956a4f8801d721a40670c410b6 /debian/rules
parent86d78437127a05e4361ab171237e7d9b47325eda (diff)
Integrate Debian packaging changes
debian/control: * restructure to make it easier to incorporate further changes * update package descriptions * update project URL debian/rules: * use proper hardening syntax * restructure to make it easier to incorporate further changes * remove useless comment * add cleanup and test overrides debian/compat: update compatibility version Change-Id: Ibf62448eee1df914d21834f5b54831e3f642b79c Related: OS#1694
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules12
1 files changed, 11 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index f7f941b3..80ba0b2c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,7 +5,7 @@ DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
#export DH_VERBOSE=1
-export DEB_BUILD_HARDENING=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
@@ -20,3 +20,13 @@ override_dh_autoreconf:
override_dh_auto_configure:
dh_auto_configure -- --enable-trx
+
+override_dh_clean:
+ dh_clean
+ $(RM) tests/package.m4
+ $(RM) tests/testsuite
+
+# Print test results in case of a failure
+override_dh_auto_test:
+ dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+