aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-04-05 14:08:11 +0200
committerosmith <osmith@sysmocom.de>2019-05-20 10:28:45 +0000
commitad7b8bee71e78e5a046b65898e181b8c48be3974 (patch)
treeb470c41fb38149ce6c3a29e549fe434d343c594d /debian/rules
parentc6c2aa9ecdeba74de4ddc51320de5fd674a5702a (diff)
debian: create -doc subpackage with pdf manuals
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 5 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 27de11b8..94bed0ea 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,7 +16,7 @@ override_dh_strip:
dh_strip --package=osmo-bts-trx --dbg-package=osmo-bts-trx-dbg
override_dh_auto_configure:
- dh_auto_configure -- --enable-trx --with-systemdsystemunitdir=/lib/systemd/system
+ dh_auto_configure -- --enable-trx --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
override_dh_clean:
dh_clean
@@ -26,3 +26,7 @@ override_dh_clean:
# Print test results in case of a failure
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf