aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-07-02 18:48:55 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-07-02 18:57:29 +0200
commit91e7bd7d30285681e268fb6d28d310339eae2491 (patch)
tree385becc41914b972e91f25258fa5279cb419783f /debian/rules
parenta1f09d910559352754ef36a6eeb754c38efd8f2d (diff)
debian: Create dbg package for osm-bts-virtual
Previously all debug symbols were being stored in osmo-bts-trx-dbg. Change-Id: I9524234cb47c9d5d8e5dc2148c21746e1cd0f10c
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 80ba0b2c..32d9342b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,8 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
dh $@ --with=systemd --with autoreconf --fail-missing
override_dh_strip:
- dh_strip --dbg-package=osmo-bts-trx-dbg
+ dh_strip --package=osmo-bts-virtual --dbg-package=osmo-bts-virtual-dbg
+ dh_strip --package=osmo-bts-trx --dbg-package=osmo-bts-trx-dbg
override_dh_autoreconf:
echo $(VERSION) > .tarball-version
@@ -29,4 +30,3 @@ override_dh_clean:
# Print test results in case of a failure
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
-