aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/libcommon-cs/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-05-10 12:50:31 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-11-24 16:58:30 +0100
commitc69ee8527c8ec88bdbff820d0a8aa706502516a5 (patch)
tree7ff8998763f0a2bb20333516d8163e1baa8ad54b /openbsc/src/libcommon-cs/Makefile.am
parent16606c9007ae97bbb0ca796384381b4decceee91 (diff)
Add empty libcommon-cs
This will gradually soak up code shared by libbsc and libmsc. Change-Id: If34e2bd38a099d0799238337468d56e0305ab8ae
Diffstat (limited to 'openbsc/src/libcommon-cs/Makefile.am')
-rw-r--r--openbsc/src/libcommon-cs/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/openbsc/src/libcommon-cs/Makefile.am b/openbsc/src/libcommon-cs/Makefile.am
new file mode 100644
index 000000000..f3921ba5f
--- /dev/null
+++ b/openbsc/src/libcommon-cs/Makefile.am
@@ -0,0 +1,20 @@
+AM_CPPFLAGS = \
+ $(all_includes) \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir) \
+ $(NULL)
+
+AM_CFLAGS = \
+ -Wall \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(LIBOSMOVTY_CFLAGS) \
+ $(LIBOSMOABIS_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
+ $(NULL)
+
+noinst_LIBRARIES = libcommon-cs.a
+
+libcommon_cs_a_SOURCES = \
+ common_cs.c \
+ common_cs_vty.c