aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMax <ikj1234i@yahoo.com>2013-12-27 20:36:42 -0500
committerMax <ikj1234i@yahoo.com>2013-12-27 20:36:42 -0500
commit6eb2e677d35a3babef39ac529bad807f918c8f86 (patch)
tree23e5221d0393a5efa5306c0b23776785931d2a2c /CMakeLists.txt
parentff8845d4998f379868ee7c647f3f6c3f0a1f025a (diff)
initial checkin
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..c4f45da
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 2.6)
+project(gr-op25 CXX C)
+
+add_subdirectory(op25/gr-op25)
+add_subdirectory(op25/gr-op25_repeater)
+
+########################################################################
+# Create uninstall target
+########################################################################
+configure_file(
+ ${CMAKE_SOURCE_DIR}/cmake/cmake_uninstall.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake
+@ONLY)
+
+add_custom_target(uninstall
+ ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake
+)